Additional tools

Merge two datasets

File ‣ Merge two files: Used to merge two experiments.

Both experiments have to include identical channel and metadata information!

Multichannel demo-/kymographs

Tools ‣ Create multichannel demo-/kymograph: Create multicolor demo- or kymographs by combining up to three individual channels in one image.
  1. Create a demo-/kymograph and save it as a Matlab fig-file.
  2. Create a demo-/kymograph from the same cells for a different channel and save it as a Matlab fig-file.
  3. (Repeat for a 3rd channel if appropriate)
  4. Call Tools –> Create multichannel demo-/kymograph and select the fig-files and colors for the individual channels.
The combined demo- or kymograph might look nicer, if the colormap of the individual demo- or kymographs is adjusted. This needs to be done for each demo- or kymograph separately.

Export annotated images

Tools ‣ Save screenshot: Save current segmentation view as png, jpeg or eps file (sequence). Creates a new figure and copies all cells (+overlays) from the segmentation view to it. Afterwards the figure content can be modified.

Export annotated movie

Tools ‣ Save movie: Create movie of your current segmentation view as image file sequence (png, jpeg or eps) or movie file (avi and mp4). Time metadata can be added as label of customizable fontsize and the framerate and movie quality can be set.

Custom Matlab scripts

The cell/stalk segmentation data can be accessed in the following way for customized processing.

Run

BacStalk_data = guidata(gcf);

to retrieve the underlying data.

The segmentation data is stored in the structure

BacStalk_data.frames